صدور اکسپرت

صدور اکسپرت

نحوه صدور اکسپرت

هنگامی‌که یک استراتژی را در ویرایشگر باز کرده‌اید می‌توانید آن را به صورت یک اکسپرت صادر کنید. برای انجام این کار روی دکمه Export  در نوار ابزار کلیک کنید.

چندین گزینه صدور وجود دارد:

  • Expert Advisor for MT4 – صدور یک اکسپرت برای متاتریدر ۴ ؛
  • Expert Advisor for MT5 – صدور یک اکسپرت برای متاتریدر ۵ ؛

اکسپرت صادر شده ۱۰۰٪ کد MQL محلی است و به کتابخانه ها یا اندیکاتورهای ثالث نیاز ندارد.

نحوه فراخوانی اکسپرت در متاتریدر

MetaTrader 4
  1. به File> Open Data Folder بروید
  2. از لیست پوشه‌ها، پوشه MQL4 را باز کنید
  3. پوشه Experts را باز کنید
  4. فایل اکسپرت را وارد کنید
  5. به متاتریدر برگردید
  6. به Navigator بروید (اگر باز نیست از View> Navigator باز کنید)
  7. در کادر Navigator راست کلیک کنید. روی Refresh از منو کلیک کنید. اکسپرت شما باید در هدایت گر در زیر Expert Advisors ظاهر شود.
  8. نمودار خود را که می‌خواهید اکسپرت تان را در آن قرار دهید باز کنید
  9. برای اضافه کردن اکسپرت به نمودار آن را از جعبه Navigatorبه نمودار بکشید و رها کنید.

 

 

استفاده از شماره‌های انحصاری مختلف

هنگامی‌که شما می‌خواهید چندین اکسپرت را در یک نماد مشابه معامله کنید، آنها نیاز خواهند داشت تا بین موقعیت‌های یکدیگر تفاوت قائل شوند. متاتریدر به ما اجازه می‌دهد تا این کار را با استفاده از یک شماره انحصاری برای هر اکسپرت انجام دهیم. کارگاه اکسپرت برنامه‌های اکسپرت را با یک شماره انحصاری تصادفی درون سازی شده در اکسپرت صادر می‌کند تا موقعیت‌های خود را از سایر اکسپرت‌ها در هنگام معامله متمایز کند. با این وجود شما می‌توانید مطمئن شوید که هر اکسپرت که شما در همان نماد معامله می‌کنید دارای شماره انحصاری متفاوت می‌باشد. اگر این اتفاق بیافتد، می‌توانید شماره انحصاری را از کد اکسپرت یا گزینه‌های ورودی اکسپرت تغییر دهید.

 

 

 

MetaTrader 5
  1. به File> Open Data Folder بروید
  2. از لیست پوشه، پوشه MQL5  را باز کنید
  3. پوشه Experts را باز کنید
  4. فایل اکسپرت را وارد کنید
  5. به متاتریدر برگردید
  6. به Navigator بروید (اگر با نبود از View> Navigator باز کنید)
  7. در کادر Navigator راست کلیک کنید. روی Refresh از منو کلیک کنید. اکسپرت شما باید در Navigator در زیر Expert Advisors ظاهر شود.
  8. در Navigator بر روی نام اکسپرت راست کلیک کنید. از منو Modify را انتخاب کنید
  9. یک ویرایشگر کد باز خواهد شد. از منوی بالای پنجره روی Compile کلیک کنید
  10. ویرایشگر کد را ببندید
  11. برای اضافه کردن اکسپرت به نمودار آن از جعبه Navigator به نمودار بکشید و رها کنید.

 

لطفاً توجه داشته باشید که شما نمی‌توانید به طور همزمان چندین اکسپرت را در همان نماد در MT5 معامله کنید.

 

 

اگر شما از یک مجموعه شماره انحصاری متفاوت برای هر اکسپرت استفاده کنید، حساب های محافظت شده MT5 (Hedging accounts ) می‌توانند در هر نماد چندین اکسپرت را معامله کنند.

 

 

اجرای اکسپرت

هنگامی‌که اکسپرت را به نمودار می‌کشید و رها می‌کنید، یک پنجره محاوره ظاهر خواهد شد. شما می‌توانید گزینه های اکسپرت را در برگه Inputs بررسی کنید.

شما می‌توانید اکسپرت را در تستر استراتژی متاتریدر تست کنید.

 

شما باید در تست متاتریدر نتیجه یکسانی را همانند کارگاه اکسپرت دریافت کنید. در صورت بروز اختلافات، بررسی کنید که آیا از داده ها، کارمزدها و کمیسیون‌ها یکسان استفاده می‌کنید. اگر اختلاف هنوز وجود داشته باشد، لطفاً یک مبحث در انجمن پشتیبانی باز کنید.